The Embold on-premise installer assumes a “blank” operation system, with no software other than the default packages installed. If you want to use an already in use virtual machine or server, please let us know beforehand to avoid dependency conflicts during the installation. 
The same holds true for docker based installation. If the docker is already running containers on the same host, please get in contact with us before the installation to avoid conflicts. 

Embold is installing the following dependencies automatically by default: 

Dependency NameVersion
PostgreSQL9.6.8
Java1.8.0_171
Apache Tomcat7.0.82.0
Node.jsv8.11.3

If any of those applications are already installed, please let us know, since a dependency conflict is very likely.